Wiki Home

VFPSystem Requirements


Namespace: VFP
I couldn't find anywhere a list of system requirements for the various foxpro versions. Does one exist? Or should one be started?

I found a very good tag at the end of the VFP 8 announcement here on the wiki in VFP8Released - it was more detailed than the one on the Microsoft web site. In particular, it listed system requirements for the development system as W2K or higher and for the deployed code as W98 or higher. That's the kind of information I'm looking for. But since it didn't come from the Microsoft web site, where did it come from? And how authoritative is/was the source? Michael Wagner

Probably from the VFP 8 Help topic "Installing Visual FoxPro".

Operating system: Developing applications with Visual FoxPro 8.0 is supported only on Microsoft Windows 2000 Service Pack 2 or later, and Windows XP. You can create and distribute run-time applications for Windows 98, Windows Me, Windows 2000 Service Pack 2 or later, and Windows XP.
Note Installation on Windows NT 4.0 Terminal Server Edition is not supported.

Can someone tell me the equivalent info for VFP 9? Michael Wagner

VFP 9.0 has the same requirements as VFP 8.0 -- Craig Berntson

http://msdn.microsoft.com/vfoxpro/productinfo/sysreqs/default.aspx

Thanks, whoever put that in, but that misses my point. The page above shows the development system requirements - I was asking in addition for what is required for run-time deployment. VFPSupported OS answers the question nicely. Michael Wagner
Hi, I'm running VFP 9 under Windows Millenium, and it works perfectly. You just need to copy GDIPLUS.DLL from a Windows XP installation to the Windows 9x installation, and put it in the folder C:\WINDOWS\SYSTEM. I also have tried this on Windows 98 and it worked fine. I think it's a marketing invention that you must run VFP on Windows 2000 or XP. -- ChristianDrège


See Also VFPSupported OS

Category Requirements
( Topic last updated: 2005.08.30 08:45:04 AM )