Wiki Home

Wiki Edit Problem


Namespace: VFP

Camel Case Problem: I added ourselves to FoxPro 2 To VFP Consultants. I added my Companies Name as TGFConsultants. Expecting this to be accepted as Camel Case. But was not. I am new to Wiki? Any ideas? Anyway to force Wiki to take something as a potential page or a link?

The wiki expects to see an interstitial lowercase letter between the capital letters. Otherwise, to force a link, prefix the word with "?", like this: TGFConsultants -- Steven Black
OK, re: the discussion below, I found the problem: When more than one instance of WC is serving the site, as is usually the case, it's possible that consecutive user requests be served across several instances, and the update from one instance isn't immediately being seen by the others. See VFP Table Concurrency. I'll fix this... -- Steven Black

When I edit a topic a second time the changes made in the first edit are missing. I can resolve this if I go to Recent Changes between edits. Joe Kuhn

This happens most of the time but not always. I haven't been able to isolate the difference. Joe

What you are seeing is your browser cache. In IE, check your settings under Tools ~ Internet Options ~ General ~ Temporary Internet Files ~ Settings button. My "Check for newer versions of stored pages" is set to "Automatically". -- Steven Black


So is mine. Joe Kuhn
So is mine and I just had the problem big-time. -- Pamela Thalacker

Are you people using the Back button on your browser? Are you waiting for the whole page to download (it takes quite a while for all the category data to load) before saving a topic edit? I've never had a problem clicking the Edit on the topic once the page comes back from the save operation. What browsers? I'm used IE4, 5 and 6 in here without this sort of problem, and I've done a fair share of topic editing since the Wiki came online. -- ?df

Ok Steve, after I clicked Save to push my above changes to the Wiki, the page came back down with it's pre-changed content. I clicked to Recent Changes and saw that I was tagged on the page as last edit, clicked the topic and that page load showed the edit. I've not made any browser setting changes here in ages. Is it possible your server is double-clutching on us and not causing the new page content to appear after the save? -- ?df

But it doesn't always happen. Refresh seems to help. Joe Kuhn

Better description of problem: go into edit mode, make a change, save, look for the change just made. I just did this and the change wasn't there. I've always assumed 'save' would force a copy of the new page to be sent to my browser. Refresh certainly does. I'm 0 for 2 today so far. Joe Kuhn

Joe, what sort of connection to the net are you using? You may be behind a caching proxy; either at your company or your ISP is being helpful. -- ?CFK
I've seen the problem at home and at work. At home I have a dial up 64KB modem through worldnet.att.net. At work we've got our own web site/email accounts through some ISP, I don't know who with a T1 always connected scenerio.

The strange thing is this didn't used to be a problem. And I haven't changed settings at work or at home. I have IE 6 at home and IE 5 at work. Joe Kuhn

Just to be clear: It seems like your edits are always being saved in the wiki's database, but sometimes you don't see the change. Correct? - CFK Yep. Joe Kuhn

I can confirm the behavior. For the last couple of days I have seen the same weirdness. I will make an edit and click Save, the page that comes next does not show my changes. If I return to recent and select the page there I then do see the results of my edit. I have also NOT made any changes in settings this just started a couple of days ago.

Just now it didn't do it this time, I saw the changes immediately.
Now this is weird. When I typed the comment in black above I immediately saw the changes after Saving. However when I edited again to type the blue comment the changes were not displayed to me until I went back to Recent changes and reloaded the page.
--JimBooth

P1 - ok, I just experienced it on the kwh wiki. I did just get a new cable modem, switched from the one given to me by Media One to a new one supplied by AT&T - the new system "might" be caching web pages. -- ?CFK

P2 - and now it just happened to the above paragraph. -- I opened a new browser, Recent Changes, click, data was here. So at least I am convinced that the data is being saved. -- ?CFK

P3 - and again. This time I hit ^R in IE 6.0, and up come the updated page. -- CFK http://flowers-shop.sitesfree.com/

P4 - and again. This time I made a point of comparing the time stamp at the top of the page (07:28:48) to the time shown on Recent Changes (07:30:19) -- ?CFK

Woa! even nuttier! after I saved P4 (the time stamp notes), the text was on the resulting page. So I hit "edit" to note that after 4 edits I did get a fresh page, and the edit box did not have P4. Ok, I am going to stop now. -- ?CFK

Yep. Seen that too. Joe Kuhn
Category Wiki
( Topic last updated: 2007.04.27 07:09:40 PM )